返回 登录
0

还在为了post分析js?还在正则查找?还在穿透填表?out啦!

大家知道网站登陆用post是最快的,post无非就是抓包找到post参数,这个比较简单,难就难在模拟参数,比如密码一般被js加密,你得分析js,有些网站post时会有一堆奇怪的参数,这些参数有的可以在源代码中找到,有些又得分析js,好不容易全部揪出来,网站稍加改动,又得重新分析一遍。

所以很多人选择了一劳永逸的方法:”超级文本框”

超级文本框其实就是调用了ie内核,什么js,什么参数统统自动处理,配合穿透填表,即可完成所有登陆

但超级文本框需要加载整个页面,很多不需要都加载了。
由于加载了不需要的内容,速度上跟直接post会差很远很远!

那有没有既可以像超级文本框一样不用管js,又可以和直接post一样效率的方法呢?

我开始想到的是,用超级文本框登陆,获取cookie后,后续操作用post,两全其美!

可是,想法是好的,就是无法实现,原因就是从超级文本框上提取的cookie不全!!!原来很多网站都把重要的cookie设置为httponly属性
而超级文本框是不给提取的,如果大家有提取的方法,请留言分享!反正我是折腾半天没搞定

后来在本论坛求助,很快有位@ovo555 大神指出一条明路:“如果要用浏览器取得推荐你CEF3++浏览器”

经过一番折腾,真的可行!
我由于也是刚刚获取到httponly cookie,就开心的过来跟大家分享,至于具体高阶应用,请自行参悟

我可以给大家形容一下比较完美的方案:
用CEF3++浏览器登陆获取关键cookie,关键参数不需要用正则,直接用诸如“Template.浏览器_取对象(div).innertext”获取,接下来即可脱离浏览器,直接用post完成后续发帖等操作
由于CEF3++浏览器是易语言开源的,你可以打造一个你的专属浏览器,想怎么折腾都可以。

.版本 2
.支持库 spec

.子程序 _按钮1_被单击
.局部变量 cookie, CElibCookie

cookie.创建 ()
' cookie.枚举所有 (&接收cookie)
' 记得获取按钮要点两下才能调试输出结果,至于为什么,你搞明白了告诉我
cookie.枚举指定 (“填写你要获取的网址”, 真, &接收cookie)
调试输出 (“++++++++”)
调试输出 (cookieget)


.子程序 接收cookie
.参数 cookie指针, 整数型
.参数 下标, 整数型
.参数 总数量, 整数型
.局部变量 cc, 文本型

cookieget = cookieget + Template.浏览器_取COOKIE名称 (cookie指针) + “:” + Template.浏览器_取COOKIE内容 (cookie指针) + “;”
返回 ()

新手想要学习易语言不管是想要做个人软件还是修改器或是别的什么人除了要多动手实践最重要的还是经验的交流欢迎有需要的的小伙伴进易语言交流群89965907来一起交流问题学习经验(记得备注哦),我把各种基础到高级教程资料都放到里面了,欢迎一起交流学习。

评论