返回 登录
2

易语言 循环判断 无限循环 参数传值调用子程序

新人不可错过

.版本 2
.支持库 spec
.子程序 _按钮1_被单击, , , ,
.局部变量 传值给子程序测试, 整数型
传值给子程序测试 = 10  ' 把10赋值给“变量”
子程序测试 (传值给子程序测试)  ' 执行“子程序测试“便会接收 变量内的值"10",
.子程序 子程序测试
.参数 测试接收传值参数, 整数型, , 参数可接收 变量,以及全局变量 等用法
延时 (100)
处理事件 ()  ' 随意,适当用
.判断循环首 (测试接收传值参数 > 1)
    测试接收传值参数 = 测试接收传值参数 - 1  ' 减去1
    调试输出 (“参数相减”, 测试接收传值参数)  ' 测试输出的参数值,减少麻烦用此调试无需转换文本,
    .如果真 (测试接收传值参数 = 5)  ' 参数减到 5自然就会结束循环了
        调试输出 (“参数值等于”, 测试接收传值参数, “者跳出循环”)
        跳出循环 ()  ' 不用[ 跳出循环() ]的情况,可 直接赋值 ,0,给参数。 >1自然就不循环了
    .如果真结束
    延时 (2000)
.判断循环尾 ()
调试输出 (“子程序结束的参数值”,测试接收传值参数)  ' 这里可以条用别的子程序执行,参数用法便能全局控制多线程等,,,成大神指日可破

新手想要学习易语言不管是想要做个人软件还是修改器或是别的什么人除了要多动手实践最重要的还是经验的交流欢迎有需要的的小伙伴进易语言交流群89965907来一起交流问题学习经验(记得备注哦),我把各种基础到高级教程资料都放到里面了,欢迎一起交流学习。

评论